Daily Archives: 2013-03-02

为你的Rails 3 准备升级到 Rails 4

一个新的 Rails 版本即将发布了,随之带来了很多的修改、依赖和新特性。 让我们看一下,要使用 Rails 4,你需要为你的应用准备些什么。 升级的方式 要为 Rails 4 做好准备最简单的方法就是让你的应用运行在 Rails 3.2 上。如果你目前还不是使用 Rails 3.2,建议使用小版本方式升级,就是说从 3.0 升级到 3.1 ,然后再从 3.1 升级到 3.2 一些方法将在 Rails 4 中被完全删除,我们应该知道这些,并事先做好准备。 Rails 4 只支持 Ruby 1.9.3+ Rails 4 将只支持 Ruby 1.9.3 或者更新的版本,因此必须确保你的应用可在 Ruby 1.9.3 … Continue reading

Posted in ruby on rails | Leave a comment

nokogiri安装错误(openSUSE)

系统openSUSE 12.2 Ruby: rvm安装1.9.3 gem install nokogiri 安装nokogiri出现下面问题 Building native extensions. This could take a while… ERROR: Error installing nokogiri: ERROR: Failed to build gem native extension. /bin/ruby extconf.rb checking for libxml/parser.h… yes checking for libxslt/xslt.h… no —– libxslt is … Continue reading

Posted in ruby on rails | Tagged | Leave a comment